[messages] [Technical Support & Bugs] Can not open modules

Geralt przemyslaw26 at interia.pl
Sat Oct 12 18:44:12 MST 2013


I can not open modules. 

I have windows 7 64 bit, i5-2500K 3.3GHz, 8 GB RAM, AMD Radeon HD 6900
Series (I don't remember exactly).
Vassal version 3.2.8

Java version: 
java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

I had problems to run vassal, but I managed to do it. Now when I want to
load/open module It loads infinitely. 

Copy from the log (for one of modules):
2013-10-13 03:25:02,074 [0-main] INFO  VASSAL.launch.StartUp - Starting
2013-10-13 03:25:02,077 [0-main] INFO  VASSAL.launch.StartUp - OS
Windows 7 6.1
2013-10-13 03:25:02,077 [0-main] INFO  VASSAL.launch.StartUp - Java
version 1.7.0_40
2013-10-13 03:25:02,077 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.8
2013-10-13 03:25:02,122 [0-AWT-EventQueue-0] INFO 
VASSAL.launch.ModuleManager - Manager
2013-10-13 03:25:12,123 [0-SwingWorker-pool-1716070515-thread-1] INFO 
VASSAL.launch.AbstractLaunchAction - Loading module file D:\!Planszowe\X
wings miniatures\Star_Wars_X-Wing_Miniatures_Game-4.5.1.vmod
2013-10-13 03:25:12,301 [0-SwingWorker-pool-1716070515-thread-1] INFO 
VASSAL.tools.io.ProcessLauncher - launching C:\Program
Files\Java\jre7\bin\java -classpath lib\Vengine.jar -Xmx121M
-DVASSAL.id=2 -Duser.home=C:\Users\Geralt -DVASSAL.port=63347
VASSAL.tools.image.tilecache.ZipFileImageTiler D:\!Planszowe\X wings
miniatures\Star_Wars_X-Wing_Miniatures_Game-4.5.1.vmod
C:\Users\Geralt\AppData\Roaming\VASSAL\tiles\a9a37e867843854936a9cb3981df1129fff4107c
256 256
2013-10-13 03:25:12,866 [2-main] INFO 
VASSAL.tools.image.tilecache.ZipFileImageTiler - Starting
2013-10-13 03:25:12,874 [2-main] ERROR
VASSAL.tools.image.tilecache.ZipFileImageTiler - 
java.io.IOException: Nieprawid³owe dojœcie
	at java.io.FileInputStream.readBytes(Native Method) ~[na:1.7.0_40]
	at java.io.FileInputStream.read(Unknown Source) ~[na:1.7.0_40]
	at java.io.BufferedInputStream.read1(Unknown Source) ~[na:1.7.0_40]
	at java.io.BufferedInputStream.read(Unknown Source) ~[na:1.7.0_40]
	at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[na:1.7.0_40]
	at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[na:1.7.0_40]
	at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[na:1.7.0_40]
	at java.io.InputStreamReader.read(Unknown Source) ~[na:1.7.0_40]
	at java.io.BufferedReader.fill(Unknown Source) ~[na:1.7.0_40]
	at java.io.BufferedReader.readLine(Unknown Source) ~[na:1.7.0_40]
	at java.io.BufferedReader.readLine(Unknown Source) ~[na:1.7.0_40]
	at
VASSAL.tools.image.tilecache.ZipFileImageTiler.main(ZipFileImageTiler.java:92)
~[Vengine.jar:na]
2013-10-13 03:25:12,886 [2-main] ERROR
VASSAL.tools.image.tilecache.ZipFileImageTiler - 
java.net.SocketException: Permission denied: create
	at java.net.Socket.createImpl(Unknown Source) ~[na:1.7.0_40]
	at java.net.Socket.<init>(Unknown Source) ~[na:1.7.0_40]
	at java.net.Socket.<init>(Unknown Source) ~[na:1.7.0_40]
	at
VASSAL.tools.image.tilecache.ZipFileImageTiler.main(ZipFileImageTiler.java:133)
~[Vengine.jar:na]
2013-10-13 03:25:12,887 [2-main] INFO 
VASSAL.tools.image.tilecache.ZipFileImageTiler - Exiting

This "java.io.IOException: Nieprawidłowe dojśœcie" it is partly in
polish. It means something like invalid access/handler (?) or something
similar - I'm not sure :).

What can be wrong?

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=42377#p42377


More information about the messages mailing list