[messages] [Technical Support & Bugs] Can not run Vassal

GMAT thegeneralstaff at gmail.com
Sat Sep 14 13:22:32 MST 2013


Hello,

I installed the Vassal 3.8.2. But it can not run on my laptop. When I
click it to start, it always shows a window stated that there is an
internal errors.

I had tried to run Vassal since the beginning of this year, but always
with this problem.
It it not work even I run it under administrator.

Please help me to find out the problem. I really want to have a chance
to run Vassal on my laptop.

 My laptop information:
Model: Dell XPS M1530
OS: Vista SP2 32bit
CPU: Intel Core 2 Duo T7500 2.20GHz 
Memory: 2GB 
Video: GeForce 8600M GT 
VASSAL: 3.2.8
Java: 1.7.0_25

The Error Log is attached 

2013-09-14 21:20:24,032 [0-main] INFO  VASSAL.launch.StartUp - Starting
2013-09-14 21:20:24,037 [0-main] INFO  VASSAL.launch.StartUp - OS
Windows Vista 6.0
2013-09-14 21:20:24,037 [0-main] INFO  VASSAL.launch.StartUp - Java
version 1.7.0_25
2013-09-14 21:20:24,037 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.8
2013-09-14 21:20:24,176 [0-AWT-EventQueue-0] INFO 
VASSAL.launch.ModuleManager - Manager
2013-09-14 21:20:24,434 [0-main] ERROR VASSAL.tools.ErrorDialog - 
java.lang.NullPointerException: null
	at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source)
~[na:1.7.0_25]
	at sun.awt.shell.Win32ShellFolder2.access$400(Unknown Source)
~[na:1.7.0_25]
	at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source)
~[na:1.7.0_25]
	at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source)
~[na:1.7.0_25]
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
~[na:1.7.0_25]
	at java.util.concurrent.FutureTask.run(Unknown Source) ~[na:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
~[na:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
~[na:1.7.0_25]
	at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Unknown
Source) ~[na:1.7.0_25]
	at java.lang.Thread.run(Unknown Source) ~[na:1.7.0_25]

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=42025#p42025


More information about the messages mailing list