[messages] [Technical Support & Bugs] Unable to save game or write log due to out of memory

Joel Uckelman uckelman at nomic.net
Tue Sep 17 12:22:19 MST 2013


Thus spake mintroll:
> I'm playing the Space Empires 4X Module, I've been playing a game a
> while and wanted to save it (so I could go to sleep), but VASSAL would
> not let me save... I tried 'save game' and 'begin/end log' to try save
> something. Both times I got 'VASSAL out of memory: change heap size and
> restart'
> 
> I'd happily increase the heap size and restart... but it wouldn't let me
> save my game first.
> 
> In the end I lost my game (yes, I should have been saving more often) -
> failure to save seems a issue to me.
> 
> 
> Is there a way to force a save... is this an issue other people have. Or
> is it just the Space Empires module?

the problem is that VASSAL ran out of memory while saving. If you
tried to "force" a save somehow, you'd have the same problem.

You need to increase your max heap in the module preferences.
 
-- 
J.


More information about the messages mailing list