[messages] [Module Support] Italia Socket Error issue

markgame mccandlesm at aol.com
Thu Sep 26 10:52:05 MST 2013


I've encountered a problem trying to use Italia_v1.1.vmod

The problem does not show up with the two other modules I tried, D-Day
at Omaha Beach and Triumph and Tragedy.
Vassal Message:

Socket Error

The socket over which the Module Manager communicates has had a fault.
Please restart VASSAL.
[This solution, of course, merely repeats the problem]

 I have:
Model: iMac  27", Mid 2011
Operating System: Mac OS X Lion 10.7.5 (11G63b)
CPU: 2.7 GHz Intel Core i5
Memory: 4 GB 1333 MHz DDR3
Video Card: AMD Radeon HD 6770M 512 MB
VASSAL Version: 3.2.8
Java 7 version 40
Module: Italia_v1.1vmod
My web browsers are Safari Version 6.0.5 (7536.30.1) and Firefox 23.0.1.
I do not have a separate firewall program.
The steps I took were to click on my downloaded VASSSAL 3.2.8, Click
Open Module under FIle, find and select the module in the folder I've
stored it in, click Open.  A box opens labelled "Processing Image TIles"
 which remains at 0% and says below that 0% bar: Tiling images/Base
Layer.png.  Then the Socket Error window opens.

The details of the error message are in the attached file, the first 10
lines of which are included here:

java.util.concurrent.ExecutionException: java.io.IOException: return
value == 1
	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
	at java.util.concurrent.FutureTask.get(FutureTask.java:83)
	at org.jdesktop.swingworker.SwingWorker.get(Unknown Source)
	at
VASSAL.launch.AbstractLaunchAction$LaunchTask.done(AbstractLaunchAction.java:620)
	at VASSAL.launch.Player$LaunchAction$1.done(Player.java:188)
	at org.jdesktop.swingworker.SwingWorker$5.run(Unknown Source)
	at
org.jdesktop.swingworker.SwingWorker$DoSubmitAccumulativeRunnable.run(Unknown
Source)
	at org.jdesktop.swingworker.AccumulativeRunnable.run(Unknown Source)
	at
org.jdesktop.swingworker.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(Unknown
Source)

I apologize for sending a private message first, without all the needed
information-- for some reason I didn't notice the New Topic button or
compute that it was the way to post a new subject.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: VASSAL Socket Error PDF.pdf
Type: application/pdf
Size: 45439 bytes
Desc: not available
URL: <http://www.vassalengine.org/pipermail/messages/attachments/20130926/116de54c/attachment-0001.pdf>
-------------- next part --------------

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=42141#p42141


More information about the messages mailing list