[messages] Edit: Re: [Technical Support & Bugs] It won't load

lakendter lakendter at yahoo.com
Sat Feb 1 20:55:00 CET 2014


[This message has been edited.]

2014-02-01 14:19:27,722 [0-main] INFO  VASSAL.launch.StartUp - Starting
2014-02-01 14:19:27,726 [0-main] INFO  VASSAL.launch.StartUp - OS
Windows 7
2014-02-01 14:19:27,726 [0-main] INFO  VASSAL.launch.StartUp - Java
version 1.7.0_51
2014-02-01 14:19:27,726 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.2
2014-02-01 14:19:27,760 [0-AWT-EventQueue-0] INFO 
VASSAL.launch.ModuleManager - Manager
2014-02-01 14:19:35,431 [0-main] ERROR VASSAL.tools.ErrorDialog - 
java.lang.StackOverflowError: null
	at java.lang.ClassLoader.getClassLoadingLock(Unknown Source)
~[na:1.7.0_51]
	at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_51]
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
~[na:1.7.0_51]
	at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_51]
	at VASSAL.preferences.Prefs.read(Prefs.java:193) ~[Vengine.jar:na]





Model = HP Pavilion dv6 notebook PC
Operating System = windows 7 professional, SP1
CPU = Intel Core I5 CPU M540 @2.53 GHz
Memory = 8 GB
Video Card = Not sure where to locate
Vassal version = I believe 3.2.2.  Vassal won't load to confirm, but
this is the latest install file I have
Java version = java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) Client VM (build 24.51-b03, mixed mode, sharing)


My PC died when my UPS box died.  Despite being a laptop, the dead UPS
shut of my PC.  I got the computer to restart and it is running fine
again.  

However, something has gotten corrupted with Vassal.  Everything else is
working fine.
It appears to be something screwed with Java.  I uninstalled, then
reinstalled Java.  I still couldn't get it to work.  
I found a suggestion about Java and appended my path variable to add
this to the end of it:  C:\Program Files (x86)\Java\jre7\bin
After that is when I got the above Java version message.  
Even after this I still can't get Vassal to load.  Any idea what I need
more to do with Java?

I tried system restore to an earlier point and it failed to fix this. 
In addition, it corrupted other programs.  System restore isn't the
answer.


NOTE:  Vassal was running 100% fine before the PC lock up.  I know
something got corrupted, but no clue what.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=43767#p43767


More information about the messages mailing list