[messages] [Technical Support & Bugs] Vassal-3.2.10 wont start

uckelman uckelman at nomic.net
Sat Feb 15 00:29:19 CET 2014


"sithstalker" wrote:
> Thus spake sithstalker:
> 
> > > I downloaded the 3.2.11 version and installed it. It started from
> > the
> > > checked box on the finish screen initially, but once closed, it
> > would
> > > not restart. So, basically, the problem is the same as with the
> > 3.2.10
> > > installation, except that the Launch file in jre6 in no longer
> > there.
> > 
> > Uninstall and reinstall, but *don't* launch from the installer at
> > the
> > end of the install. Do you have the same problem then?
> 
> Yes, the program only starts the first time it is launched, whether
> after installation, or after a restart of the PC. Running as admin
> does not resolve this situation.

The likely problem is that another process is holding open a file that
VASSAL needs to write (or possibly read) on launch.


> The lib folder has many files, but those that remained after uninstall
> were " swing-worker-1.2.jar", "smack.jar", "sf4j-api-1.7.6.jar",
> "miglayout-core-4.2.jar", "logback-core-1.1.1.jar",
> "logback-classic-1.1.1.jar", "java-getopt-1.0.13.jar", "janino.jar",
> "commons-lang-2.5.jar", "commons-io-1.4.jar", "commons-compiler.jar".

This is just what you'd expect to see if these files were being held
open when the uninstaller was running. Windows won't permit open files
to be deleted. Did you have any version of VASSAL running when you
launched the uninstaller?

Please post the contents of the errorLog from immediately after a failed
launch attempt. Also, check the task manager to see if java.exe or
anything similar is already running before a failed launch attempt.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=43944#p43944


More information about the messages mailing list