[messages] [Module Design] Independent, Non-linear UNDOs

Charles McLellan cgmclellan2000 at knology.net
Mon May 5 18:40:11 CEST 2014


__Problem:__ I have tried a number of times to reproduce the results
achieved by Tim McCarron but have not been successful. I am attaching
the module with which I have been working. I only set the Return to
Start trait on two units, the 1st and 2nd German Infantry in hex TRC
0924.

The Return to Start option was not included on the list of traits
displayed on the right click menu. Moving the units also did not bring
the Return to Start option into the trait list.

__Current Differences Between Models:__ The only intentional difference
that I made in coping Tim's work was substituting "TRC4a" for Tim's
"Map" in Game Piece Photo Definitions \ Return to Start \ Send to
Location \ Return me back to where I came from \ Board.

__Problems Encountered During Copying:__ On the first attempt to
duplicate Tim's work, I mistyped A "#" in the first position of
"$CurrentlyY$" in the Game Piece Photo Definitions \ Return to Start \
Dynamic Property \ StartYLocation \ SetupInitialLocation \ New Value. A
note identifying the error was displayed upon opening the module. I
corrected the character in an edit of the module.

When first coping the "Reset the location [Global Key Command], the
"Button Icon:" was "white" where Tim's was "gray." Selecting the default
brought what appeared to be a small unit icon not from this module. 
Going then to "Select" brought an icon page off of my computer. I
selected an icon, but nothing appeared. When I open the module, a report
that the icon I had selected was not recognized by the module. I
subsequently changed the image from ".ico" to ".png," substituted the
new image in the module image file and changed the ".ico" to ".png" in
the module build file. That seemed to satisfy the module. On subsequent
edits, the "white" reset button had changed to "gray" without any action
on my part.

When saving the edit, the Save would not process. A "Java" window opened
in the upper left of the monitor. I did not capture the information as
to why. On a retry, a Save As… was forbidden in the location where the
module was located (C:\ Program Files \ VASSAL \ mods) but allowed in a
location under "C: \ Users \ Charles."  I saved there with a "TRC5"
title. A VASSAL module with the edit changes was located at and
subsequently loaded from that location. 

After re-edits, I had problems saving and had to again Save As…  This
time as TRC6.vmod. This will be the attached module.

__Attempts to Correct Results:__ I tried a couple of things in an
attempt to duplicate Tim's results:

I moved the "Initialize pieces" group up the tree to duplicate the
position in Tim's Demo2 module. Still didn't bring "Return to Start"
trait into menu. Returned the group back to the end position on the
tree.

I changed the "TRC4a" "Board" to just "TRC" because the grid
identification of a hex is for example "TRC4  0924". It didn’t alter
anything. I changed back.

__Differences Between Modules:__ Differences that I note between the
Deme2 and TRC4 modules that I didn't change:

1. Of course, the map is different and there are many more units with
different images and more traits. 
2. Tim's module does not produce a log file. Moving units in the TRC4v2
module does.
3. Tim's units do not show a movement path. Moving units in the TRC4v2
module do.
4. Tim's works; mine doesn't.

__Possible Problems Between Models:__ In the TRC6 module there is a
extra line preceding Game Piece Photo Definitions \ Return to Start \
Dynamic Property in both the StartXLocation and StartYLocation
properties. This line is "CTRL V" trait and it does appear on the trait
list. I have not tired to remove or shift the trait yet.

__Data:__ My computer is a Dell Inspiron with a Windows 7, SP1 32 bit
operating system with an AMD Semprus Processor LE-1300 2.30 GHz and
3.0GB RAM, C: of 596 GB with 262 GB free. Java is 7 Up-date 55 (build
1.7.0_55-b14). VASSAL is 3.2.8. Internet is Internet Explorer
11.0.9600.17105, Update Version 11.0.7 (KB2964358).

__Other Concerns:__ When I went to attach the TRC6.vmod from C: \ Users
\ Charles it was not there. There was a TRC5.vmod which was an earlier
module that required the use of TRC6.vmod as a Save As… as the
TRC5.vmod caused some Java conflict when Save was attempted. I also
notice that there are three "temxxx.zip" files two of which seem to be
VASSAL modules in disguise and one a VASSAL build file. So, I am going
to attach just the TRC4v2 module from C: \ Program Files \ VASSAL \
Modules here, then the other four files from C: \ Users \ Charles in
subsequent attachments.

Let me know if you need any more information.

__The file is too big, maximum allowed size is 256 KiB.__

Guess I try some other ways to add the attachments.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=44815#p44815


More information about the messages mailing list