[messages] [Technical Support & Bugs] Intitial Tiling Fails for Large Graphics (Maps)

reg129 reg129 at wideband.net.au
Sun Jun 14 14:22:27 CEST 2015


Hi,  
I have looked for previous posts of this type and didn't find any that
were similar so I am posting this.

I just downloaded two Vassal modules from the Decision Games website and
found that the "Cobra" module works fine but the "War between the
States" fails to tile correctly and hangs at 26% leaving the tiling
window open.  After a while it brings up the game selection menus (which
work) but only displays a single fragment of the main map in the top
left corner. I suspect other graphics may also be missing.  I have
attached the two error logs, one successful for 10MB files and the other
unsuccessful for 13MB files.

The only difference I can see is the size of the graphic file being
processed and that the conversion switches to FileImageTypeConverter and
the process then fails.


> 
> 2015-06-14 17:54:08,204 [2-main] INFO 
> VASSAL.tools.image.tilecache.FileArchiveImageTiler - Tiling
> images/WbtS edited.jpg
> 2015-06-14 17:55:06,678 [2-main] INFO 
> VASSAL.tools.image.FallbackImageTypeConverter - Switching to
> FileImageTypeConverter...
> 2015-06-14 17:56:53,626 [2-main] ERROR
> VASSAL.tools.image.tilecache.ZipFileImageTiler - 
> java.net.SocketException: Connection reset by peer: socket write error


I tried an old module that I was working on a while back (under Vassal
3.2.6) with a 13MB map file and it fails in a similar manner to WBTS. 
It used to tile just fine.  I tried increasing initial memory heap size
and it made no difference.

Hardware: Compaq NC8430 with T5600 processor and 3GB memory recently
upgraded to Win8.1 from XP.  Java 1.8.0_45 also recently installed
(which may or may not have anything to do with it).  Otherwise Vassal
seems to be running just fine.

Cheers,
Reg
.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Vassal_Error_Log_2015-06-14_18-59_OK.txt
URL: <http://www.vassalengine.org/pipermail/messages/attachments/20150614/bfdfd500/attachment-0002.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Vassal_Error_Log_2015-06-14_17-56.txt
URL: <http://www.vassalengine.org/pipermail/messages/attachments/20150614/bfdfd500/attachment-0003.txt>
-------------- next part --------------

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=49036#p49036


More information about the messages mailing list