[messages] [Technical Support & Bugs] 3.2.13 will not launch under my OS X 10.5.8

Joel Uckelman uckelman at nomic.net
Mon Mar 2 14:36:29 CET 2015


Thus spake fgilbert2:
> For 1)  -bash:
> /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands/java:
> Bad CPU type in executable

This is what I thought we might see. We can solve your problem now.

The reason you're seeing different behavior between VASSAL 3.2.14 and
3.2.15 is that the launch scripts look for versions of java in a 
different order.

The reason that 3.2.15 isn't working for you is that 3.2.15 looks for
Java 6 before Java 5---and your Java 6 installation is broken. In
particular, you've installed Java 6 for the wrong CPU architecture.
(My guess is that your Mac has a PowerPC CPU, not a newer Intel CPU.)

The solution is to uninstall Java 6. Once you do that, 3.2.15 will find
Java 5 first and should launch properly.

If you want to use a version of Java other than Java 5, you need to find
one built for the ppc architecture instead of intel.

-- 
J.


More information about the messages mailing list