[messages] [Technical Support & Bugs] Linux Mint error with VASSAL 3.2.17

Rhett rtr101 at hotmail.com
Tue Apr 18 21:17:00 CEST 2017


I found the answer. It had nothing to do with VASSAL.

Linux Mint 18.1 installs as default both the Java runtime JDK8 and JDK9.
JDK9 is only a development version and does not support Freetype fonts.
I had to uninstall JDK9 and then update Java alternatives:


Code:

$ sudo update-java-alternatives --auto
$ java -version
openjdk version "1.8.0_121"
OpenJDK Runtime Environment (build
1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13)
OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)




With openjdk 1.8.0_121 VASSAL works.

I hope this helps others on their way to use Linux.


Rhett

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=53444#p53444


More information about the messages mailing list