[messages] [Module Support] X-wing module - Problem moving pieces

Joel Uckelman uckelman at nomic.net
Tue May 2 01:20:51 CEST 2017


Thus spake darthjeff81:
> I just downloaded the latest vassal engine and the newest x-wing module.
> I had to install java to run it, and confirmed I had the latest version.
> When I start a game and import my squad, I have trouble moving pieces
> from the player hand to the board. When moving pieces, they don't have a
> "ghost" during movement, and just pop up where I drop them. This only
> occurs when moving pieces around the player hand or from the player hand
> to the board. I am able to move pieces around the board and from the
> board to the player hand with no problems. Probably related, when I have
> the map window open, any new vassal window appears behind the map
> window, and old windows, specifically the "controls" window will not
> appear in front of the map, even when active. If I try and move the
> pieces quite a few times, I can -eventually- get the piece to the board,
> but it takes 10-30 tries. 
> 
> I have tried uninstalling and reinstalling the vassal engine, the x-wing
> module and java. I have even tried downloading older versions of each,
> but there was no change. I tried restarting my computer, to no avail.
> The problem occurred on both offline and online games. I tried an online
> game with a friend, and they could move the pieces but I could not. He
> did see them moving. 
> 
> I am running a fairly new MacBook air, with OS X el capitan version
> 10.11.6.

It's a known issue with the current version of Java on Macs.
 
-- 
J.


More information about the messages mailing list