[messages] [Technical Support & Bugs] Can't save log files error has recurred

Joel Uckelman uckelman at nomic.net
Thu May 4 00:47:05 CEST 2017


Thus spake Edrains via messages:
> Hi Joel, last week you helped me solve the 128 MB Java heap size error
> message.  I got it to work twice, but now the problem has recurred.  I'm
> getting the same Java memory error message as before, I can't save log
> files, and Vassal won't quit normally (have to force quit).

I haven't had time to reply since then, sorry.
 
> I've been doing what you told me to do last week, which worked last
> week.  But now, I'm throwing away the old prefs file in the app data
> folder, but each time the same error message appears, and then a new
> prefs file is being created with an initial size of 256MB and a maximum
> of 512.  I'm not sure where this is coming from, since my preferences in
> two places (vassal and the module) are set to 512/1024.  
> 
> What am I missing?
> Thanks in advance for any help or advice!
> Ed Rains

I don't quite understand what you're doing. Are you _setting_ the max
heap to 1024MB yourself? And at 1024MB max heap you're sometimes failing
to load the module due to insufficient memory? Is this correct?

-- 
J.


More information about the messages mailing list