[messages] [Technical Support & Bugs] Can't save log files error has recurred

Edrains edrains at aol.com
Fri May 5 15:52:04 CEST 2017


Hi Joel, this is what is in the error log when the Maximum Heap Size Too
Large error message appears on the screen (error message not closed yet,
still on the screen);

2017-05-05 08:28:03,689 [0-main] INFO  VASSAL.launch.StartUp - Starting
2017-05-05 08:28:03,692 [0-main] INFO  VASSAL.launch.StartUp - OS
Windows 7 6.1
2017-05-05 08:28:03,693 [0-main] INFO  VASSAL.launch.StartUp - Java
version 1.8.0_111
2017-05-05 08:28:03,693 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.16
2017-05-05 08:28:03,762 [0-AWT-EventQueue-0] INFO 
VASSAL.launch.ModuleManager - Manager
2017-05-05 08:28:16,448 [0-SwingWorker-pool-26964746-thread-1] INFO 
VASSAL.launch.AbstractLaunchAction - Loading module file E:\VASSAL\The
Battle for Normandy 3_16.vmod
2017-05-05 08:28:17,211 [0-SwingWorker-pool-26964746-thread-1] INFO 
VASSAL.launch.TilingHandler - No images to tile.
2017-05-05 08:28:17,214 [0-SwingWorker-pool-26964746-thread-1] INFO 
VASSAL.launch.AbstractLaunchAction - Loading module The Battle for
Normandy
2017-05-05 08:28:17,219 [0-SwingWorker-pool-26964746-thread-1] INFO 
VASSAL.tools.io.ProcessLauncher - launching C:\Program Files
(x86)\Java\jre1.8.0_111\bin\java -Xms512M -Xmx1024M -DVASSAL.id=1
-DVASSAL.port=52407 -Duser.home=C:\Users\grains -Duser.dir=E:\VASSAL -cp
lib\Vengine.jar VASSAL.launch.Player --load -- E:\VASSAL\The Battle for
Normandy 3_16.vmod
2017-05-05 08:28:17,279 [0-SwingWorker-pool-26964746-thread-1] INFO 
VASSAL.tools.io.ProcessLauncher - launching C:\Program Files
(x86)\Java\jre1.8.0_111\bin\java -Xms64M -Xmx128M -DVASSAL.id=1
-DVASSAL.port=52407 -Duser.home=C:\Users\grains -Duser.dir=E:\VASSAL -cp
lib\Vengine.jar VASSAL.launch.Player --load -- E:\VASSAL\The Battle for
Normandy 3_16.vmod
2017-05-05 08:28:17,883 [1-main] INFO  VASSAL.launch.StartUp - Starting
2017-05-05 08:28:17,888 [1-main] INFO  VASSAL.launch.StartUp - OS
Windows 7 6.1
2017-05-05 08:28:17,888 [1-main] INFO  VASSAL.launch.StartUp - Java
version 1.8.0_111
2017-05-05 08:28:17,888 [1-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.16
2017-05-05 08:28:17,888 [1-main] INFO  VASSAL.launch.Launcher - Player
2017-05-05 08:31:44,413 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - VASSAL images folder found at
jar:file:/E:/VASSAL/lib/Vengine.jar!/images/
2017-05-05 08:31:44,417 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family network-server created for
network-server.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family go-down created for
go-down.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family network-idle created for
network-idle.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family VASSAL created for
VASSAL.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family calculator created for
calculator.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family go-up created for go-up.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family VASSAL-jabber created for
VASSAL-jabber.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family jabber created for
jabber.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family bug created for bug.png
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family yes created for yes.svg
2017-05-05 08:31:44,418 [1-IconFactory-preload] INFO 
VASSAL.tools.icon.IconFactory - Icon family no created for no.svg
2017-05-05 08:31:45,489 [1-AWT-EventQueue-0] WARN 
VASSAL.launch.BasicModule - The Battle for Normandy version 3.16

As a semi-knowledgeable person, it looks to me like the VASSAL
ProcessLauncher is initiating Java twice - the first time with
sufficient memory, and the second time with insufficient.  What do you
think?

I do have the following settings in place inside Java (the jre Runtime
Environment Settings):  -Xms512m.  Doesn't that set a minimum of 512 MB
for Java to use?  Why is it reverting to 64/128?  

And is the whole startup sequence being duplicated twice?

This is over my head, for sure.  

Thanks in advance!

Ed

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=53578#p53578


More information about the messages mailing list