[messages] [Module General Discussion] Looking for Guidance

rrvs spideratj at aol.com
Sat May 13 15:58:05 CEST 2017

I realize now your previous shorthand for "another counter" was for the
send to location... that should've been obvious to me.  For that test, I
should've put CardSide in their own prototypes (red, blue, yellow,
etc)... so you'd have two prototypes in each card: one for their
assigned color (which would be different for each player's cards, if I
have the game's set-up right) and one for all the cards in general
(which I called "pieces" for some reason).  The prototype holding the
CardSide marker (or the marker itself, as I have it in that test) has to
be above the generic prototype for the cards in trait order. So if all
the players have their own cards, with their own colors, then CardSide
should work as the "another counter" selection property.

Re your expressions... as I say I prefer the older style, so don't quote
me on these... but for the gkc: Gameboard needs to be in quotes (like
you have in the second one) because that's its actual name, while
CardSide (second one in that line) should be free of any additions, and
the whole thing needs {} around it I think.  I'd write it as:

{cardselect=="Secondary" && CurrentBoard!="Gameboard" &&

... which I just tried in my test mod and it seems to work.

I had it written (in old syntax) as:

For the Send to Location one however... I think I've mentioned that I
have no idea how to use =~ in the new syntax.  So I'm sorry but I can't
write that out in the new format, except (or so I thought) to remove
that portion of it altogether.  I thought simply removing that part
would work (as long as there would be no other cards of each color type
on the Gameboard), but found I couldn't get it to work.  I tried both of

{CurrentBoard=="Gameboard" && CardSide==CardSide}


...and neither worked for me.  It might be that I'm still on 3.2.16...
or it might be that I'm just not very good with the new syntax. Anyway,
I tried it with the old syntax (with that part removed), just to see if
the idea itself was okay, and it did seem to work:


So anyway I would recommend, for the Send to Location at least, just
using the complete old syntax of:


...which I definitely know works.  Hope this all made sense.

Read this topic online here:

More information about the messages mailing list