[messages] [Technical Support & Bugs] Illegal reflective access warning

gmking gmking503 at gmail.com
Fri Aug 3 01:06:07 CEST 2018


I am getting the same error message when I start up Vassal in Linux.

Here are my specs:
Computer: Dell XPS 8500
CPU: Intel Core i7-3770 processor 3.40 GHz
Video: NVIDIA GeForce GT 620 1GB DDR3
OS: Linux Ubuntu 18.04
Java: Openjdk 10.0.1
Vassal: 3.2.17
Vassal Modules producing error: Talavera_&_Vimeiro_v0.6.vmod & 
  The_Sun_of_Austerlitz_mod_0.0.1-v3.2.2.vmod  (probably any module will
produce the error on my machine, but I thought two examples were enough
to start with)

This is reported in terminal screen when the Vassal engine starts up,
before I can try to load a module:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by
VASSAL.tools.image.ImageIOImageLoader
(file:/home/mitch/Public/Vassal/Vassal%20Engine/lib/Vengine.jar) to
field sun.java2d.cmm.ProfileDeferralMgr.deferring
WARNING: Please consider reporting this to the maintainers of
VASSAL.tools.image.ImageIOImageLoader
WARNING: Use --illegal-access=warn to enable warnings of further illegal
reflective access operations
WARNING: All illegal access operations will be denied in a future
release

Vassal starts up in spite of the error.  Here is the complete error log
opening Vassal and before I try to load a game module:
2018-08-02 18:35:33,454 [0-main] INFO  VASSAL.launch.StartUp - Starting
2018-08-02 18:35:33,455 [0-main] INFO  VASSAL.launch.StartUp - OS Linux
4.15.0-29-generic
2018-08-02 18:35:33,456 [0-main] INFO  VASSAL.launch.StartUp - Java
version 10.0.1
2018-08-02 18:35:33,456 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.17
2018-08-02 18:35:35,001 [0-AWT-EventQueue-0] INFO 
VASSAL.launch.ModuleManager - Manager

After I tried to open a module I get an "Uncaught Exception" dialog box,
asking me to send a report of the bug to the Vassal developers. 
Unfortunately the error box fails to send you the information about this
bug.  After attempting to send the report, the dialog box reports it
failed and asks me to report the bug through this forum.

I have attached a text file showing the error logs I get when I try to
open each of the two named modules.

I hope you are able to help with this bug.  I had Microsoft's forced
Windows 10 updates trash two of my computers at home this spring.  I
desperately want to move away from Microsoft's products.  Being able to
run Vassal in Linux is important in my efforts to slip away from
Microsoft.

Thank you for any assistance you are able to give me.

Mitch King
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Vassal Error Logs.txt
URL: <http://www.vassalengine.org/pipermail/messages/attachments/20180802/331a0060/attachment.txt>
-------------- next part --------------

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=55573#p55573


More information about the messages mailing list