[messages] [Technical Support & Bugs] Cant open vassal New user

Joel Uckelman uckelman at nomic.net
Fri Jan 19 00:32:08 CET 2018


Thus spake Eras:
> Hi there :)
> 
> I'm having a similar problem on mac as well. I'm also unable to submit
> my error log.
> 
> Here's my log:
> 2018-01-16 22:43:44,763 [0-main] INFO  VASSAL.launch.StartUp - Starting
> 2018-01-16 22:43:44,766 [0-main] INFO  VASSAL.launch.StartUp - OS Mac OS
> X 10.12.6
> 2018-01-16 22:43:44,766 [0-main] INFO  VASSAL.launch.StartUp - Java
> version 9.0.4
> 2018-01-16 22:43:44,766 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
> version 3.2.17
> 2018-01-16 22:43:45,645 [0-main] ERROR VASSAL.tools.ErrorDialog - 
> java.lang.NoSuchMethodError:
> com.apple.eawt.Application.addApplicationListener(Lcom/apple/eawt/ApplicationListener;)V
> 	at
> VASSAL.launch.ModuleManagerMacOSXStartUp.setupApplicationListeners(ModuleManagerMacOSXStartUp.java:36)
> ~[Vengine.jar:na]
> 	at
> VASSAL.launch.ModuleManagerMacOSXStartUp.initSystemProperties(ModuleManagerMacOSXStartUp.java:31)
> ~[Vengine.jar:na]
> 	at VASSAL.launch.ModuleManager.<init>(ModuleManager.java:280)
> ~[Vengine.jar:na]
> 	at VASSAL.launch.ModuleManager.main(ModuleManager.java:183)
> ~[Vengine.jar:na]

The problem you're having here is that one of the Apple components
VASSAL relies on no longer exists in Java 9. Until someone has time
to investigate what we should use instead, you can use an earlier
version of Java as a workaround.

-- 
J.


More information about the messages mailing list