[messages] [Technical Support & Bugs] Vassal does not start on OS X

Basset alazrac76 at gmail.com
Sun Jan 21 13:07:20 CET 2018


Dear friends, 
 
   got this error message when trying to run Vassal. Any idea? I updated
Java, but still... Any incompatibility? Should I update the OS?

    Thanks a lot in advance! 

2018-01-21 13:01:44,915 [0-main] INFO  VASSAL.launch.StartUp - Starting
2018-01-21 13:01:44,921 [0-main] INFO  VASSAL.launch.StartUp - OS Mac OS
X 10.11.6
2018-01-21 13:01:44,921 [0-main] INFO  VASSAL.launch.StartUp - Java
version 9.0.4
2018-01-21 13:01:44,921 [0-main] INFO  VASSAL.launch.StartUp - VASSAL
version 3.2.17
2018-01-21 13:01:45,873 [0-main] ERROR VASSAL.tools.ErrorDialog - 
java.lang.NoSuchMethodError:
com.apple.eawt.Application.addApplicationListener(Lcom/apple/eawt/ApplicationListener;)V
	at
VASSAL.launch.ModuleManagerMacOSXStartUp.setupApplicationListeners(ModuleManagerMacOSXStartUp.java:36)
~[Vengine.jar:na]
	at
VASSAL.launch.ModuleManagerMacOSXStartUp.initSystemProperties(ModuleManagerMacOSXStartUp.java:31)
~[Vengine.jar:na]
	at VASSAL.launch.ModuleManager.<init>(ModuleManager.java:280)
~[Vengine.jar:na]
	at VASSAL.launch.ModuleManager.main(ModuleManager.java:183)
~[Vengine.jar:na]

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=54769#p54769


More information about the messages mailing list