[messages] [Module Design] Return To Deck Not Functioning

Popestar ghost.popestar at gmail.com
Tue Jun 12 23:46:42 CEST 2018


And I have yet another question that I'm hoping to get some
information/help on.

I have a deck (we'll call it Deck A) which contains several cards.  Each
of the cards has the following properties:

- Basic Piece
- Prototype - Misc Token
- Return To Deck

The Prototype only has the property Marker - Layer=Misc Token (which is
used for stacking/rendering purposes).

When I move cards off the deck to the main board, I get no right-click
menu.  I checked, and I have the following defined in Return to Deck:

- Menu Prompt:  Return to Token Pool
- Keyboard Shortcut:  NULL (field is blank)
- Deck:  Deck A

I've tried rearranging the order of the 2 properties I can (Prototype
and Return to Deck; Basic Piece is not movable), and this yields no
results.  The cards in Deck A aren't being placed onto a deck space on
the main board, so I'm not sure if that's the case.  I do know that I
have the Return to Deck option in another deck I'm using (Deck B), and
that deck is on a deck space on the main board.  And when I right-click
on Deck B on the main board, I get the right-click menu.

So my question:  What am I doing wrong with Deck A?  Do I have to place
the cards from Deck A onto a deck space on the main board to get the
right-click menu?  Do I potentially have something wrong with the Return
to Deck Property?

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=55387#p55387


More information about the messages mailing list