[messages] [Technical Support & Bugs] So close to running Vassal on Ubuntu, but a late-stage crash

Knarfton fpacella at albany.edu
Wed Mar 7 09:45:36 CET 2018


Hi all, 

I'm running  Ubuntu 16.04 LTS off a Chromebook shell. I presently have
Java installed thru apt-get. Running 
Code:
java -version

 tells me it's:


Code:
java version "9.0.4"
Java(TM) SE Runtime Environment (build 9.0.4+11)
Java HotSpot(TM) 64-Bit Server VM (build 9.0.4+11, mixed mode)



As I try and fire the engine up, Java throws an error at me detailed
"Unable to Launch Application. Reason: Could not parse launch file.
Error at line 1." 

The Launch File details are as follows: 
----------------------------
#!/bin/sh

#
# Execute this file to launch VASSAL on MacOS or Linux
#

# Find absolute path where VASSAL is installed
INSTALL_DIR=$(cd "$(dirname "$0")"; pwd)

# Launch VASSSAL
java -Duser.dir="$INSTALL_DIR" -classpath "$INSTALL_DIR"/lib/Vengine.jar
VASSAL.launch.ModuleManager "$@"
-------------------------------

How do I go about fixing this?

It's worth pointing out that I'm absolutely a novice at this whole
computer shell OS installing stuff. 

Thanks for any and all help that can be given.

_______________________________________________
Read this topic online here:
http://www.vassalengine.org/forum/viewtopic.php?p=54966#p54966


More information about the messages mailing list