Create account / Log in
Bug 4795 - insufficient documentation of 'pieceName' vs. 'PieceName'
insufficient documentation of 'pieceName' vs. 'PieceName'
Status: ASSIGNED
Product: VASSAL
Classification: Applications
Component: Documentation
3.1.20
All Mac OS
: unspecified normal
: ---
Assigned To: Brian Reynolds
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 12:58 CEST by David Goering
Modified: 2020-08-11 21:21 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Goering 2012-09-20 12:58:13 CEST
Split from bug 4769.  

Unless and until one of the properties 'pieceName' or 'PieceName' is renamed they should be made distinct in the designerguide and other documentation.

1)  Incorporate this explanation by Brent Easton into the documentation:
"
The pieceName property (reference by $pieceName$ in the label) returns the name
of the piece WITHOUT the label, so you can use it in the format for the label
to add the label text to the piece name. $pieceName$ only exists locally within
the text label trait.

The PieceName property ($PieceName$) is something completely different. It is a
Basic piece property that returns the entire piece name, including the name
generated by the text label. So if you reference $PieceName$ within a text
label, you get an infinite loop as the text label tries build the piece name
using $PieceName$ which needs the text label to build the piece name using
$PieceName$ which needs the text label...

Essentially, PieceName or $PieceName$ should never be used in the Text Label
Name Format, you should only be using the two options in the insert drop-down,
pieceName and label.
"

2)  Add 'pieceName' to the table in the Basic Piece section, page 44, immediately adjacent to 'PieceName'.
  
3)  Contrast 'pieceName' with 'PieceName' in the Text Label section, page 64.

4)  There are five uses of 'PieceName' in examples in the Using Properties chapter, pages 17 and 18.  Would these examples be more realistic if 'pieceName' were used instead?