General

From VASSAL
Jump to: navigation, search

The Devil's Cauldron

General VASSAL Usage

Online Help

The VASSAL user guide is installed on your machine when you install VASSAL and is accessible by selecting User's Guide from the Help menu. A Quick Start guide is also available from this menu.

Online play or PBEM play?

VASSAL supports both online play through the VASSAL server and PBEM play by the creation of Log Files containing a series of moves that can be replayed by your opponent.

The VASSAL server is accessed through the Server button Server btn.png. See the On-line VASSAL documentation for details of how to setup online play.

For PBEM play, you need to select options from the File Menu to create or load Log Files.

File Menu

The File menu is the key to loading, viewing and creating VASSAL Save and Log files:

Menu.png

Startup Files

The Startup Files menu option allows you to choose from the predefined Scenario Startup files. The startup files contain notes with the details of the scenario and have all of the units needed to play selected and placed either on the map, or on the scenario card ready to be placed.


Save File or Log File?

It is important to understand the difference between a Save File and a Log File.

A Save File is a snapshot of your game containing the current position and state of all the pieces in your current game. Save Files are useful for sending an initial startup file to an opponent. For normal PBEM game play, you should use Log Files as a Save File only shows the final state of play, it does not show the individual moves or die rolls that got the game to that state.

A Log File contains a Save File from the start of a play session PLUS a replay of all the moves made by yourself or your opponent during the play session, plus all of the comments you have typed into the Chat Window. After loading up a Log File you use the Step Button Step btn.png to replay your opponents moves one by one. It is important to remember to always Open a Log File before making any game moves that you want your opponent to see.

If you want to include your opponents moves in your own log file, you can do this by opening his log file and starting to replay his moves. At the point you want to start copying, open your own log file and keep replaying his moves. The moves from his log file will now be echoed into your own log file. You can also add Chat Window comments to the log file.

Load Continuation allows you to load and replay additional log files while keeping the current game open. This is useful to replay a series of log files, or to create one large game replay log file from the individual turn log files.


Chat Window

The Chat Window is the large area at the top of the screen where messages appear:
Chat.png
Some messages are generated automatically by VASSAL when you load and save games, or when you move or manipulate game pieces. You can also type messages into the Chat line and these will be saved in the currently open Log File, or if you are playing online, will be seen immediately by your opponent.