Create account / Log in

Problems running Peer to Peer

Topics related to the main Vassal engine.

Moderators: uckelman, Tim M

Problems running Peer to Peer

Postby angatyr » June 12th, 2021, 7:57 pm

I am trying to create a Peer to Peer connection on my local network.

However one of my computers has VMWare player installed which creates a couple of virtual network adapters - each on their own network. For some reason, unlike any other program known to me, Vassal insists on using one of these adapters giving it an IP address not on my local network - hence making it impossible to connect to anything.

Is there a way to force Vassal to use the correct network adapter?

/regards
Henrik
angatyr
 
Posts: 11
Joined: May 16th, 2021, 3:52 pm

Re: Problems running Peer to Peer

Postby jrwatts » June 14th, 2021, 8:27 am

You don't say which OS you're running on. If it's Windows 10, it looks like ForceBindIP may be able to do what you want (https://r1ch.net/projects/forcebindip). Note: I've never used ForceBindIP myself, just found it with a Google search on how to force Java to use a specific network adapter.
jrwatts
 
Posts: 355
Joined: April 29th, 2020, 10:30 pm

Re: Problems running Peer to Peer

Postby angatyr » June 14th, 2021, 5:54 pm

Thx for the suggestion - that might come in handy.

And yes, the problem is on Windows 10. I temporarily solved it by disabling the VMWare virtual network adapters in the control panel. As a side note: I have a Proxmox server running, so I am slowly phasing my VMWare virtual machines out. After that I can just uninstall VMWare Player and the problem is gone :D

/henrik
angatyr
 
Posts: 11
Joined: May 16th, 2021, 3:52 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests