Create account / Log in

No versions after 3.4.3 will open

Issues with the Vassal engine.

Moderators: uckelman, Tim M

Re: No versions after 3.4.3 will open

Postby coylote » December 15th, 2020, 12:34 pm

After reading other comments, I do have an errorLog. When I open it, it reads:

2020-12-15 06:26:50,674 [0-main] INFO VASSAL.launch.StartUp - Starting
2020-12-15 06:26:50,680 [0-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2020-12-15 06:26:50,680 [0-main] INFO VASSAL.launch.StartUp - Java version 15
2020-12-15 06:26:50,680 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.4.11
2020-12-15 06:26:50,805 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
coylote
 
Posts: 3
Joined: December 15th, 2020, 12:05 pm

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 19th, 2020, 7:49 pm

Yes, it's the same directory as the test build.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 20th, 2020, 11:51 pm

Ok. In that case I think the Module Manager is exiting through the other path, a bit further on from the one I modified in the test build to dump a stack trace. I've created another build which should produce a stack trace for you this time, VASSAL-3.4.12-SNAPSHOT-e592996db, which you can get here:

http://www.vassalengine.org/~uckelman/tmp/

Please try running this build as before and post the output.
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 10th, 2021, 1:44 pm

That build is not available at that link.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » January 10th, 2021, 2:02 pm

Test builds usually get removed after a few weeks.

You can try the same thing you would have had with that test build by running the 3.4.12 release:

https://github.com/vassalengine/vassal/ ... ows-64.exe

If you're not able to run 3.4.12 normally, please try running it on the command line as noted earlier in this thread. There should be some output in the terminal; please post that here.
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 10th, 2021, 2:17 pm

c:\Program Files\VASSAL-3.4.12>jre\bin\java.exe -cp lib\Vengine.jar VASSAL.launch.ModuleManager
VASSAL: C:\Users\Emper\AppData\Roaming\VASSAL
java.nio.file.FileAlreadyExistsException: C:\Users\Emper\AppData\Roaming\VASSAL
at java.base/sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:87)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:103)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:108)
at java.base/sun.nio.fs.WindowsFileSystemProvider.createDirectory(WindowsFileSystemProvider.java:506)
at java.base/java.nio.file.Files.createDirectory(Files.java:694)
at java.base/java.nio.file.Files.createAndCheckIsDirectory(Files.java:801)
at java.base/java.nio.file.Files.createDirectories(Files.java:747)
at VASSAL.launch.StandardConfig.<init>(StandardConfig.java:82)
at VASSAL.launch.ModuleManager.main(ModuleManager.java:88)
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » January 10th, 2021, 10:33 pm

Does C:\Users\Emper\AppData\Roaming\VASSAL exist? Is it a file instead of a directory? (It should be a directory, but I'm guessing from the error message that it's actually a file.)
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 11th, 2021, 10:36 pm

It exists, and it is a directory.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » January 12th, 2021, 10:17 pm

What's in it?
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 13th, 2021, 12:47 am

Many error logs, a few 'key' and 'lock' files, vassalvmoptions, and folders: tmp, tiles, prefs, ext, plugins.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby JoelCFC25 » January 13th, 2021, 2:16 pm

The lock files are definitely a problem!
JoelCFC25
 
Posts: 821
Joined: October 12th, 2010, 5:15 pm
Location: Minnetrista, MN

Re: No versions after 3.4.3 will open

Postby uckelman » January 14th, 2021, 1:23 pm

I doubt that the lock files are causing this particular problem, but deleting them won't hurt anything either.

Try renaming C:\Users\Emper\AppData\Roaming\VASSAL to something else and then running VASSAL as before. What happens when you do that?
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 14th, 2021, 3:23 pm

I renamed the Vassal folder. Old reliable 3.4.3 opens, but with no modules available. I then installed 3.4.12 and it opened for the first time (!), also with no modules available. There is a new Vassal folder, with key and lock files for both 3.4.3 and 3.4.12, along with error logs, vassal.vmoptions, and folders for tmp and prefs.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » January 14th, 2021, 7:05 pm

Ok. Then the problem was probably something to do with permissions on the old directory.

If you want your old settings back, you can delete everything inside the new C:\Users\Emper\AppData\Roaming\VASSAL and then move everything inside the old C:\Users\Emper\AppData\Roaming\VASSAL to the new one.
User avatar
uckelman
Site Admin
 
Posts: 9453
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » January 14th, 2021, 7:32 pm

I'm just loading modules anew. So far, so good. Thanks very much for your patient help. Any idea how the permissions went bad?
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

PreviousNext

Return to Technical Support & Bugs

Who is online

Users browsing this forum: No registered users and 6 guests