Create account / Log in

No versions after 3.4.3 will open

Issues with the Vassal engine.

Moderators: uckelman, Tim M

No versions after 3.4.3 will open

Postby Monkatronic » December 9th, 2020, 3:22 pm

I have Windows 64 bit. Java is up to date, 64 bit. For every Vassal version after 3.4.3 (I have tried them all), Vassal will not open. It works fine for 3.4.3 and earlier versions. Error logs are empty. What should I do?
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 9th, 2020, 11:53 pm

Thus spake Monkatronic:
> I have Windows 64 bit. Java is up to date, 64 bit. For every Vassal
> version after 3.4.3 (I have tried them all), Vassal will not open. It
> works fine for 3.4.3 and earlier versions. Error logs are empty. What
> should I do?

Check in the directory jre/bin where you have VASSAL installed. Are
java.exe and javaw.exe there?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 10th, 2020, 2:33 am

Yes, both. They are there for 3.4.3 (which works), and in the 3.4.11 folder (which does not work).
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 11th, 2020, 12:00 am

Thus spake Monkatronic:
> Yes, both. They are there for 3.4.3 (which works), and in the 3.4.11
> folder (which does not work).

If you try running VASSAL.exe from 3.4.11 from the command line, what
happens? Is there output in the terminal?

--
J.
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 11th, 2020, 7:04 pm

I'm not quite sure what that means. I opened a command prompt, changed to the Vassal directory, and tried to run vassal.exe from that. No error message, no anything.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 12th, 2020, 1:05 am

In your terminal, cd to the directory where 3.4.11 is installed. Then run:

jre\bin\java.exe -version

Does that give you any output?
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 12th, 2020, 2:49 pm

Yes:
openjdk version "15" 2020-9-15
openjdk Runtime Environment AdoptOpenJDK (build 15+36)
openjdk 64-bit Server VM AdoptOpenJDK (build 15+36, mixed mode)
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 12th, 2020, 3:50 pm

Ok. That's good. It demonstrates that the bundled Java works.

In your terminal, cd to the directory where 3.4.11 is installed. Then run:

jre\bin\java.exe -cp lib\Vengine.jar VASSAL.launch.ModuleManager

Does that give you any output? Does the Module Manager open? Is anything written to the errorLog?
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 12th, 2020, 3:57 pm

Output is "VASSAL: C:\users\Emper\AppData\Roaming\Vassal"
Nothing opened. I can't find any error log.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby Cattlesquat » December 12th, 2020, 4:10 pm

Your errorlog would be located in C:\Users\<username>\AppData\Roaming\VASSAL

It would be called errorlog-3.4.11 or something like that.
User avatar
Cattlesquat
 
Posts: 1141
Joined: December 2nd, 2019, 4:57 pm
Location: Baltimore, Maryland, USA

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 12th, 2020, 4:31 pm

There is no error log (only error logs from previous installs).
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 13th, 2020, 8:48 pm

Please try this test build:

http://www.vassalengine.org/~uckelman/t ... ows-64.exe

Launch it the same way as previously, running

jre\bin\java.exe -cp lib\Vengine.jar VASSAL.launch.ModuleManager

on the command line from the directory where the test build is installed. There should be additional output beyond "VASSAL: C:\users\Emper\AppData\Roaming\Vassal". Please paste that here.
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby Monkatronic » December 13th, 2020, 9:16 pm

Output is again "VASSAL: C:\users\Emper\AppData\Roaming\Vassal". Only that.
Thank you for your help, much appreciated.
Monkatronic
 
Posts: 14
Joined: December 9th, 2020, 3:19 pm

Re: No versions after 3.4.3 will open

Postby uckelman » December 13th, 2020, 9:30 pm

Are you certain you were running from the directory where the test build is installed?
User avatar
uckelman
Site Admin
 
Posts: 9395
Joined: December 10th, 2007, 9:48 am
Location: Durham, England

Re: No versions after 3.4.3 will open

Postby coylote » December 15th, 2020, 12:25 pm

I'm using 64bit Windows, and I am also having trouble running 3.4.11. When I try to open my computer thinks for a moment and then nothing happens. However, if I log in to the Administrator profile, it will run just fine. It's not a permissions setting that I can find. My named profile has full administrative access.
coylote
 
Posts: 3
Joined: December 15th, 2020, 12:05 pm

Next

Return to Technical Support & Bugs

Who is online

Users browsing this forum: Cundiff and 4 guests